amchagas

About

Username
amchagas
Joined
Visits
278
Last Active
Roles
Administrator

Comments

  • Hi @Ninci11 , Welcome to the Prometheus Forum! Thanks for taking the time to write things here, we really appreciate it. Now on to your questions/comments: Servo: The problem might lie on the type of servo you are using? Is this model a co…
  • Hi @jsd2, Sorry to hear you are still finding problems with your board. First is that while I was waiting on the parts I went ahead and tried to see if I could get the OS and software working on the SD card. I could power the RPi with my bo…
  • Hi @jsd2, it is very nice to get your updates and know that things are moving forward. About the capacitor, the only time we had a similar issue is when we placed the capacitor inverted. It seems unlikely that you would have placed it inverted …
  • Hi @jsd2 Glad to hear that things are progressing! * P6 and P5 are connectors that we originally designed to use for "high powered" LEDs. but in essence they are just power lines that can be controlled by a digital signal coming from the Ard…
  • Hi Jeremy, We are really sorry that you are having troubles with the PCB, the parts you ordered and the manual. Indeed it is a fail on our side to be updating things and not following up with an up to date documentation. Let's tackle this by p…
  • Great! Send us some of the images you collect with it if you can!
  • Hi Andres, I've implemented new code that I believe will solve this issue. Right now the code lives here https://github.com/amchagas/flypi/tree/load_arduinoless If you can download the repository again using the above link and test the user int…
  • Dear Andres, Welcome to the Forum! I think you are correct, this is most likely related to the fact that there is no arduino connected to the system. I've opened up an issue on GitHub https://github.com/amchagas/Flypi/issues/33 to deal with thi…
  • Hi Matt, I finally got the chance to look at your code, and it works very nicely! We would like to incorporate it into the base code. Would you like to make the change yourself using github? (this way the proper credit in the github world goes to…
  • Hi @bcallen, welcome to the Forum! I sent @mcuser2021 a direct message yesterday, did he/she get it? Since the board has been updated since the version you are using, and I never saw such a problem (where basically nothing works), my suggesti…
  • Cool that the servo is working. For that I would add the following code to the Arduino script, as the end of the "void setup" loop, but before the "Serial.println(">"); line: digitalWrite(servoOnPin, LOW);
  • Hi Matt, The servo should be a continuous rotation one. Sorry about the discrepancies in the old repository, we started with a good intention of keeping things as clear as possible (paper repo and further development), but we now realised that th…
  • Hi! thanks for the extra infos. I'm really sorry that things are not working as planned and also a bit puzzled that so many of the components are not working. Anyway, let's work through it and get it working About the arduino, the usb port shou…
  • Hi! Thanks for reaching out here, glad to see more people are building FlyPi's! This seems like a software problem. Would you mind letting us know from which repository you downloaded the code? and more or less when? Since we realized most pe…
  • Cool! Thanks for sharing Matt. Yes, the digital zoom gets noisy pretty fast, but as you say more of a camera/lens limitation...
  • Hi Matt, Sorry for the late reply. Didn't see this message 'till now. Glad to hear you managed to figure the LED problem out. We tested a new version of the ring with an extra white led per bit and didn't make a note on the repos. Adding it to t…
  • cool thanks. I can change that. If I remember correctly we couldn't find a 15 pin one from that supplier, and we wanted to stick to one supplier so that it would be easier for people in Europe/Germany to get all components. In the meantime we int…
  • Hi Matt, thanks for spotting this! Could you please tell us which material list you used? (I mean from which repository you took it?)
  • Hi Matt, Thanks for the heads up! The problem should be fixed now.
  • Hi Matt, Welcome to the Forums! I took a look at this problem, and I think I spotted the problem and found a solution for it. The problem is related to the conversion tool we are using "under the hood" in the GUI. It should be an easy fix, and…
  • Hi Christopher, Thanks a lot for the feedback. It is useful Sorry to hear about your finger. Hope it wasn't anything bad!! Also it is good to know about it, since it is something we need to consider if we succeed in getting this into more han…
  • Hi, Interesting, that is something we didn't encounter so far. And now that I think about it, something we should have considered before too... How do traditional systems solve this issue? Dichroic mirrors? I wonder if having the light guided thr…
  • Awesome!!! Super happy to hear that you managed to get things working!! If you collect data that you can share, post a photo here! we would like to see it
  • Good luck! Also this might help (there is a FAQ at the end) https://learn.adafruit.com/adafruit-neopixel-uberguide/arduino-library-installation
  • I'm not experienced enough to know if this is a wiring problem or an arduino problem, but maybe you will know This is a weird problem Ok, so it seems with baby steps we are getting somewhere.. Could you please confirm which led ring you…
  • Hi Emily, good catch! yes, you don't need the matrix parts on the arduino code. I had already removed the matrix code from development, but forgot the libraries. I updated the code on github... You can download and test that if it is easier... Ot…
  • Hi, so the order of the wires on the board is good (nice soldering! ). Just to be on the safe side, the white wire should go to data input on the ring.
  • Hi Emily, great to hear you got things up and running. Although this is not how it was supposed to run... From what you describe, it seems that there is still an issue with the communication in between the Raspberry Pi and the Arduino, and this…
  • Hi! Thanks for using the Forums and for your suggestion. We actually have no good reason to be using exclusively 3D printing, other than this is what is readily available for us at the moment. But you are completely right. As soon as we need to…
  • Hi! cool that you are trying to setup the FlyPi in your lab. This error seems to be related to the camera module. If you don't mind, answering the following questions should help us track down and debug: * Are you going to use the camera, or …