Servo motor & the 2nd version of 3D printed LED matrix holder

edited July 3 in FlyPi user forum

Hi, first thanks for the detailed instructions for such a cool microscope! We´ve managed to build one, using the PCB version 0.6 and the 2nd version of 3D-printed parts (some photos attached). It works as expected - a manual, together with some forum discussions were helpful enough to make the basic system running. Still, we have some extra questions and would be grateful for your opinion.

We´ve implemented the automated focusing of the RaspPi Camera but it seems, with the printed cogwheels provided, that it can´t really do it´s job? Servo´s limited 180 degrees of rotation covers only a small range of the lens´ thread which enables focus adjustment. Since the cogwheels are quite tightly attached to each other, it is also not possible to roughly adjust the focus manually, at the same time the cogwheels are attached. Have you also encountered this issue or is there a better way to construct the automatic focusing? We´re using Reely Analog Servo S-0009 MG. Besides increasing the cogwheel size, we were thinking a bi-directional DC motor could help us with the issues. Maybe something similar as it is described here: https://learn.adafruit.com/adafruit-dc-and-stepper-motor-hat-for-raspberry-pi/overview ? Or is there a specific reason the servo motors are used? Any suggestion would be appreciated.

Also, as it seems servo motor cogwheels and the LED matrix holder STL files are missing in the second version. Maxime kindly sent the cogwheel STL files. As for the holder, I´ve read that you haven´t update it due to lack of public interest. Just in case, I wanted to ask, wheather it has been created in the meantime?

Lastly, it´s not really crucial but we have a problem with the zap function in the LED1 module. It works well for the LED Ring but nothing happens when the zap button is pressed to control the timing of high-power UV LED. I´ve seen that the arduino sketch (flypi_development.ino) in the LED1 section doesn´t include similar zap parts as in the LED Ring section - is this why it doesn´t work and should still be added?

Thank you very much!




Comments

  • Hi @Ninci11 ,
    Welcome to the Prometheus Forum! Thanks for taking the time to write things here, we really appreciate it.

    Now on to your questions/comments:

    Servo:
    The problem might lie on the type of servo you are using? Is this model a continuous rotation servo? From what you describe, it seems you have a "regular" servo? Here is a model you can use: https://www.robotshop.com/uk/9g-continuous-rotation-micro-servo.html

    Other than that it also looks like you have the camera and the servo motor incorrectly mounted on the holder. the servo should be passing through the holder, and not just at the edge as it looks like in the photo. Maybe this is what is causing problems with the gears? (although I'll look into this again)

    The reason we chose a servo was that they don't require an extra driver (like a stepper would) and have higher torque for their size when compared to a similar sized DC motor.

    If the servo is turned off in the GUI, it should be "unlocked" and therefore users should be able to turn the gears by hand, even if there is a bit of more resistance than compared to not having the servo attached.

    Thanks for pointing out the missing files for the cogwheels! we will add that to repo!

    Matrix:
    We haven't created a matrix holder, as no one was using it (as far as we could tell). It seems that we were wrong. Maybe something to think about. It shouldn't be complicated to create one.

    LED Zap:
    That is an odd one. The code on the arduino side is not the same as the ring one, since things are mostly done on the Python side of things for the LEDs. Just to double check, did you have the led off and then setup a Zap test? or was the led on already?

    I hope this helps!

Sign In or Register to comment.